I have followed the Zenoss Core Installation Guide version 01-012013-4.2-v09 and I have installed the latest MySQL-client rpm version 5.6.10-1 and I get the following error:
Error: Package: zenoss-4.2.3-1695.el6.x86_64 (/zenoss_core-4.2.3.el6.x86_64)
Requires: mysql-client >= 5.5.13
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
I have tried using --skip-broken which doesn't work, I have tried various combinations of MySQL-client and MySQL-server 5.6 and 5.5.
Is there a magic combination of package versions to install? The exact version suggested in the pdf ( MySQL-client-5.5.28-1.linux2.6.x86_64.rpm ) doesn't exist anymore at mysql.com and the only 5.5 version available is 5.5.30-1 which doesn't work with the zenoss_core-4.2.3.el6.x86_64.rpm .
There is no mysql-client rpm (all lowercase) at any repository (epel, rpmforge) or even rpmfind.net so I am pretty stumped at this point how so many of you managed to install zenoss-core at all. Is it because I am doing the manual install and the auto-install works better?
Thanks for any leads you can give me at this point...
If like me, you still want to do a manual installation then you can download them from http://wiki.zenoss.org/download/core/mysql/
In my opinion Zenoss dev team should consider solving this problem before we run into trouble. Someday a nasty unforeseen vulnerability could be discovered and we will find ourselves in un uncomfortable position beiong forced to use an unpatched version of MySQL which is a no-go on most corporate networks. It is OK to stay with MySQL v5.5 but being locked into 5.5.27 or earlier is simply looking for trouble.
Follow Us On Twitter »
||Latest from the Zenoss Blog »||Community||Products||Services||Customers||About Us|
Copyright © 2005-2011 Zenoss, Inc.