Skip navigation
1228 Views 0 Replies Latest reply: Jul 24, 2012 11:11 AM by Duncan Wannamaker RSS
Duncan Wannamaker Newbie 1 posts since
Jul 23, 2012
Currently Being Moderated

Jul 24, 2012 11:11 AM

Problem with xmppBot py 2.6 on zenoss-3.2.1-1326.el5

Hey guys,

 

I've been trying to get this xmppBot script to work and I'm close but for some reason, when I try and start the daemon throught he admin interface I get the following error:

 

Type:

Value: (8, 'Exec format error')

 

I have searched and found that error was common to the version 1.0 of that script, and was fixed in version 1.1.  This error is coming from version 1.1 of the script.  If I manually start the script from the command line it starts ok and sends me messages: http://pastebin.com/GAvkFvxT

 

I have checked the permissions of the script, but I'm not that familiar with debugging Python or even Zenoss daemons.  Perhaps this is a common error and not related to this particular script.  Any advice or pointers would be greatly appreciated!

 

Here is my xmppBot config from /opt/zenoss/xmppBot.conf

# Config file written out from GUI
uid zenoss
first_user duncan,duncan@jabber.blah.com
jabber_pass --censored--
port 8100
pcachedir /opt/zenoss/var
jabber_host jabber.blah.com
monitor localhost
pcachesize 10
cycletime 60
zopeurl http://rhea.blah.com:8080
host localhost
logseverity 20
maxlogsize 10240
cachesize 1000
maxbackuplogs 3
jabber_user NMS-Notification
dataroot /zport/dmd
jabber_port 5222

 

Thanks,

 

Duncan

More Like This

  • Retrieving data ...

Legend

  • Correct Answers - 4 points
  • Helpful Answers - 2 points