Skip navigation
1973 Views 0 Replies Latest reply: Mar 3, 2011 4:02 AM by heyese RSS
heyese Rank: White Belt 43 posts since
Jan 26, 2010
Currently Being Moderated

Mar 3, 2011 4:02 AM

Error while trying to edit Device custom property

Hi guys,

 

Can anyone shed any light on what exactly is going on with my problem below?  We've been using Zenoss for a good while and I think it's great.  We have templates we apply to devices which use their custom properties to run various scripts with differing parameters.  This worked really well until the parameter on one such device seemed to get wiped somehow, and I can't add it back in.  When I try, I get an error like the following: -

 

Site error

An error was encountered while publishing this resource.  The requested resource does not exist.

 

In fact, if I click on the main Devices tree and try to add a new more general property into the Custom Schema, that works, but then I get the same error if I try to delete it again.

 

This is still broken - even a complete stack restart doesn't fix the problem.  I have had occasions where some kind of dodgy mysql event has messed up the event views somehow and on finding and deleting that event they start working again, but I'm not sure what the equivalent tactic would be with the Devices DB (is that Zope?).

 

An obvious point to make is that we're running Zenoss 2.5.2 (Zope 2.11.2), so we should update, but it would be nice to know what the issue is and whether this kind of thing is less likely to happen in the more recent version.

 

Any insightful comments appreciated!

More Like This

  • Retrieving data ...

Legend

  • Correct Answers - 4 points
  • Helpful Answers - 2 points