Skip navigation
2718 Views 7 Replies Latest reply: Aug 15, 2012 3:53 PM by Ryan Matte RSS
jaysnyder1usa Newbie 3 posts since
Jul 16, 2012
Currently Being Moderated

Jul 18, 2012 3:10 PM

Error when logging into Zenoss

I am getting an error after logging into the Zenoss webpage.  The error states File "/opt/zenoss/lib/python/zenoss/protocols/services/___init__.py" line 126 in _executeRequest raise ServiceResponseError|response reason, response.status, request, response, content) Service RespnseError: Service Unavailable.  This occured after a crash of the system.  I am kind of new to this and would like some guidance.

Attachments:
  • Ryan Matte ZenossMaster 653 posts since
    Mar 26, 2009
    Currently Being Moderated
    1. Jul 17, 2012 11:37 AM (in response to jaysnyder1usa)
    Re: Error when logging into Zenoss

    It sort of sounds like one of your daemons isn't running or is frozen (preventing a new instance from starting), you may have a stale pid file sitting somewhere that is causing the issue.  Become the zenoss user and do "zenoss status".  You'll see the running status of each daemon as well as a pid for each.

     

    Something like...

     

    Daemon: zeoctl program running; pid=1013

    Daemon: zopectl program running; pid=1023

    Daemon: zenhub program running; pid=1069

    Daemon: zenjobs program running; pid=1103

    Daemon: zenping program running; pid=1180

    Daemon: zensyslog program running; pid=1239

    Daemon: zenstatus program running; pid=1245

    Daemon: zenactions program running; pid=1305

    Daemon: zentrap program running; pid=1377

    Daemon: zenperfsnmp program running; pid=1382

    Daemon: zencommand program running; pid=1417

    Daemon: zenprocess program running; pid=1447

    Daemon: zenwin program running; pid=1491

    Daemon: zenwinsrvsnmp program running; pid=1527

    Daemon: zeneventlog program running; pid=1584

    Daemon: zenperfwmi program running; pid=1632

    Daemon: zensla program running; pid=1665

    Daemon: zenticket program running; pid=1678

     

    After that do "zenoss stop" and check the status again to make sure they all show as stopped.

     

    Now check to make sure that you can't find any processes that are shown as stopped but are actually still running...

     

    zenoss@lab01:~$ ps aux | grep zeoctl

    zenoss    1011  0.0  0.3  62848  9448 ?        Ssl  Jul10   0:05 /usr/local/zenoss/python/bin/.python.bin /usr/local/zenoss/zenoss/lib/python/zdaemon/zdrun.py -S /usr/local/zenoss/zenoss/lib/python/ZEO/zeoctl.xml -C /usr/local/zenoss/zenoss/etc/zeo.conf /usr/local/zenoss/zenoss/bin/runzeo

    zenoss    3035  0.0  0.0   7628   936 pts/0    S+   11:30   0:00 grep zeoctl

     

    If you find one kill it by pid, for instance to kill the example process above:

     

    kill -9 1011

     

    Repeat for each daemon that you find still running.

     

    Once you have confirmed that no daemons are running and they all show as stopped under status, check in /opt/zenoss/var for stale .pid files.  If you find any pid files in that location (for example: zenperfsnmp-localhost.pid or ZEO.pid) remove them.

     

    After you have confirmed all of the above start Zenoss again.  Let me know if this resolves the issue or not.

  • Ryan Matte ZenossMaster 653 posts since
    Mar 26, 2009
    Currently Being Moderated
    3. Jul 17, 2012 3:44 PM (in response to jaysnyder1usa)
    Re: Error when logging into Zenoss

    Are all of the services successfully starting when you do a zenoss start or are some of them failing to start?

  • Ryan Matte ZenossMaster 653 posts since
    Mar 26, 2009
    Currently Being Moderated
    5. Jul 19, 2012 10:18 AM (in response to jaysnyder1usa)
    Re: Error when logging into Zenoss

    Based on that dump you're running Enterprise 4.  Enterprise 4 is so different from Core 3 that I don't have any practical experience to help you based on.  Had they done their usual release cycle and released Core 4 before Enterprise 4 we wouldn't have this type of community support issue.  I would advise that you open a ticket with Enterprise support for your issue as it's going to be effectively impossible for anyone in the community to understand the new architechture well enough to assist you until Core 4 is released and we gain some experience with it.

  • Xu Wang Newbie 2 posts since
    Jul 4, 2012
    Currently Being Moderated
    6. Aug 14, 2012 11:24 PM (in response to jaysnyder1usa)
    Re: Error when logging into Zenoss

    I am facing the same problem and have no solution.....

  • Ryan Matte ZenossMaster 653 posts since
    Mar 26, 2009
    Currently Being Moderated
    7. Aug 15, 2012 3:53 PM (in response to Xu Wang)
    Re: Error when logging into Zenoss

    If you guys are both running Enterprise 4 you should take this up with Enterprise support.

More Like This

  • Retrieving data ...

Legend

  • Correct Answers - 4 points
  • Helpful Answers - 2 points