Skip navigation
3683 Views 5 Replies Latest reply: Jul 23, 2012 2:10 PM by july_lesev RSS
jshardlow Rank: Green Belt 98 posts since
Jun 12, 2008
Currently Being Moderated

Jul 9, 2012 10:47 AM

Is it possible to Upgrade Zenoss 4 from 4.1.70-1554 to 4.1.70-1562?

I've just tried to upgrade one of my Zenoss 4 test boxes from  4.1.70-1554 to 4.1.70-1562, but unfortunately got the following error:

jzen04 ~ $ rpm -Uvh zenoss-4.1.70-1562.el6.x86_64.rpm
warning: zenoss-4.1.70-1562.el6.x86_64.rpm: Header V3 DSA/SHA1 Signature, key ID aa5a1ad7: NOKEY
Preparing...                ########################################### [100%]
/var/tmp/rpm-tmp.FH6s8E: line 230: [: too many arguments
====================================================================
Unable to parse /opt/zenoss/etc/zope.conf for ZODB connection
parameters. EC=101

See: /tmp/zodbchk.5564

Unable to check if this is a transaction history-keeping schema.
Please contact support for details on how to test this manually
and bypass this check.

Do not attempt to upgrade until this has been properly investigated.
====================================================================
error: %pre(zenoss-4.1.70-1562.el6.x86_64) scriptlet failed, exit status 101
error:   install: %pre scriptlet failed (2), skipping zenoss-4.1.70-1562.el6


jzen04 ~ $ more /tmp/zodbchk.5564
  <relstorage>

    cache-servers 127.0.0.1:11211
    cache-module-name memcache
    keep-history false
    %include zodb_db_main.conf
  </relstorage>

 

There is a  /opt/zenoss/etc/zope.conf and Zenoss was down at the time. I'm assuming it is possible to upgrade from one beta version of Zenoss 4 to another. Is that correct?

 

If this is properly broken, then I'll log something in Jira.

More Like This

  • Retrieving data ...

Legend

  • Correct Answers - 4 points
  • Helpful Answers - 2 points