Skip navigation
1283 Views 1 Reply Latest reply: Nov 7, 2011 12:55 AM by GOM RSS
GOM Rank: White Belt 17 posts since
Oct 15, 2011
Currently Being Moderated

Nov 6, 2011 10:02 PM

Where to set timeout for Extensions commands?

I have a script in /usr/local/Extensions. Sometimes takes ~10 seconds to execute, other times it takes ~50ms to execute, just the nature of the data. When it takes a short amount of time, everything is fine, but when it takes ~10s I get:

 

"Command timed out"

 

How can I make it respect a 20 second timeout time? I tried the steps at Resolving Command Timed Out Issues ; I set zCommandCommandTimeout to 20 on the device that runs the datasource/command. Does not help. Restarted Zenoss.

 

zCommandCommandTimeout seems to be referring to "Time in seconds to wait for commands to complete on the remote device."

 

The Device running the datasource/command is not remote, it doesn't have an IP or represent a real host, it's just a dummy device to bind templates to, does that matter to where I define the timeout? In other words, this datasource is running locally on the zenoss server from the /Extensions directory, using an empty container Device. Where is the setting where I can tell it to timeout in more than 5 seconds?

 

Verified with zentestcommand, when it takes under 5 seconds, then it works fine, otherwise, command timed out at ~5 seconds.

More Like This

  • Retrieving data ...

Legend

  • Correct Answers - 4 points
  • Helpful Answers - 2 points