Skip navigation
6996 Views 5 Replies Latest reply: Dec 21, 2011 12:01 PM by Jesse Hermse RSS
mcorvalan Rank: White Belt 82 posts since
Aug 25, 2010
Currently Being Moderated

Mar 2, 2011 4:24 PM

How to check url in zenoss /// Error event is "name or service not known".

Hello:

I have a problem for check url´s.

I installed http monitor template.

For example I´d like to check: pms.mercadolibre.com/jm/jalive

 

Error event is "name or service not known".

 

My configuration in "Data Source" is:

Host name:     pms.mercadolibre.com    

Ipaddress: empty

Port: 80

URL: /jm/jalive

Regular Expression:  ML_IS_ALIVE

Redirect Behavior: ok.

 

Thanks you

 

Regards.

  • jmp242 ZenossMaster 4,060 posts since
    Mar 7, 2007

    Is there a device called pms.mercadolibre.com in Zenoss that you're binding the template to? Can you run zencommand in the foreground with debug logging and see if there's any interesting info in the error? Perhaps try a simpler check and see what works or doesn't.

     

    I've had a straight check for /index.html work fine for me, but I've never used regex's or specific sub pages.

     

    --

    James Pulver

    Information Technology Area Supervisor

    LEPP Computer Group

    Cornell University

  • Vaibhav.Narula Rank: Green Belt 78 posts since
    Sep 24, 2010

    Looking at the error looks like your  device doesnot have the ip bound to it   and  use  the following command  if template is giving issue

     

     

    check_http -H pms.mercadolibre.com -u /jm/jalive  -f --string="ML_IS_ALIVE" -S


  • remotesyslog Rank: White Belt 22 posts since
    Apr 27, 2009

    I have the same issue. My device status is "up", but it gives me that message on the console.

     

     

    Where would I type in a command?

     

    Basically, i am trying to test for connectivity, for as an example, www.google.ca. So I make a device name with "google.ca" as the name and add"httpmonitor" template to it.

     

    But this results in the "name or service not known". Any better way to do this?

  • Jesse Hermse Newbie 1 posts since
    Dec 14, 2011

    This post is old, but I see it shows not answered.  I was experiancing the same error after upgrading to 3.2.1 from 3.0 and this is what worked for me.

    Symptoms

    \Device\HTTP Class device for website did not show an IP on it's overview page.  Attempting to reset the IP address failed.

    Website runs on a load balanced cluster of 2 IIS web servers. Both servers where also monitored by Zenoss as class \Device\Server\Windows.  Server 2 showed the cluster IP as attached to one it's interfaces

     

    To resolve the issue,

    1. I installed the ZenPack Virtual IP http://community.zenoss.org/docs/DOC-5800

    2. On each of the servers I set the load balance IP (that the website responded to) to be ignored, following the instructs with the Zen Pack.

    3. Modled each server and verfied the shared IP no longer showed

    4. Modled the website device and verified it showed an IP.

    5. Clear all events for the HTTP device and wait.

     

    I.O.W.

    Before following steps above, zenoss saw things as

    Server1 IP 192.168.1.2

    Server2 IP 192,169.1.3, 192.168.1.1

    www.website.com IP none

     

    After steps above, zenoss saw things as

    Server1 IP 192.168.1.2

    Server2 IP 192,169.1.3,

    www.website.com IP 192.168.1.1

     

    I imagine this would be the same if there was only 1 web server since,at least in 3.2.1, Zenoss is very strict on IP addresses not being used by multiple devices.

More Like This

  • Retrieving data ...

Legend

  • Correct Answers - 4 points
  • Helpful Answers - 2 points