Skip navigation
12962 Views 11 Replies Latest reply: Aug 13, 2010 11:31 PM by nick.anderson RSS
nick.anderson Rank: White Belt 18 posts since
Mar 2, 2010
Currently Being Moderated

Aug 5, 2010 3:42 PM

zenjmx zenpack connection issues

It's very possible I am just being daft and missing something obvious but for the life of me I cannot seem to get the jmx zenpack to work.

 

 

Running ZenJMX 3.5.2, Zenoss 3.0, centos 5 64bit

 

The zenpack installed without issue. I installed the latest sun jre:

 

[zenoss]$ java -version
java version "1.6.0_21"
Java(TM) SE Runtime Environment (build 1.6.0_21-b06)
Java HotSpot(TM) 64-Bit Server VM (build 17.0-b16, mixed mode)

 

the zenjmx service is running

 

I have the jmx port on a java instance listening on 9898 without ssl and without auth. Connecting to that with jconsole works without issue.

 

I am a bit confused by the two templates provided by the ZenJMX zenpack one called Java and one called ZenJMX. I have tried binding both to my device and set the zJmxManagementPort to 9898. I have also tried setting the Management port inside the templates datasouces both with no success. I continue to get "error connecting to server" events for each datasource.

 

Any help is greatly appriciated.

  • jplouis ZenossEmployee 93 posts since
    May 7, 2008
    Currently Being Moderated
    1. Aug 5, 2010 3:55 PM (in response to nick.anderson)
    Re: zenjmx zenpack connection issues

    the ZenJMX template is meant to monitor the zenjmx process itself; you can ignore it

     

    Use the Java template.  While there is a zProperty for the jmx port to use, your datasources in the template are probably not referencing the zproperty

  • jplouis ZenossEmployee 93 posts since
    May 7, 2008
    Currently Being Moderated
    4. Aug 6, 2010 12:05 PM (in response to nick.anderson)
    Re: zenjmx zenpack connection issues

    Your device doesn't have a manageIP attribute which means zenjmx can't figure out the host.

  • jplouis ZenossEmployee 93 posts since
    May 7, 2008
    Currently Being Moderated
    6. Aug 6, 2010 3:47 PM (in response to nick.anderson)
    Re: zenjmx zenpack connection issues

    when you add the device it sets the IP if you let modeling occur.  SInce you already have the device you can just model it.  In 3.0 the the model device option is on the device's page in the gear menu on the bottom left

  • jplouis ZenossEmployee 93 posts since
    May 7, 2008
    Currently Being Moderated
    9. Aug 9, 2010 10:37 PM (in response to nick.anderson)
    Re: zenjmx zenpack connection issues

    can you go into zendmd and try the following, where 'device_id' is the name of your device

     

    d = dmd.Devices.findDevice('device_id')

    d.manageIp

     

    you should also be able to see the ip address in the UI on both the infrastructure device list page and the device's page.

     

    For whatever reason it doesn't seem like your device has a manage ip.  What is the last model time for the device? Time should be in the UI

More Like This

  • Retrieving data ...

Legend

  • Correct Answers - 4 points
  • Helpful Answers - 2 points