Skip navigation
18664 Views 14 Replies Latest reply: Jul 30, 2010 11:15 AM by stephenmeier RSS
Andrea Consadori ZenossMaster 863 posts since
Feb 11, 2008
Currently Being Moderated

Jul 21, 2010 3:20 AM

zenoss 3.0 search field not shown

Hi,

it's only my issue?

 

on Admin guide i see that next username there's a search combo field....

 

i've no search field as uou can see in the attachment

 

http://dev.zenoss.org/trac/ticket/7079

Attachments:
  • rebelinux Rank: Green Belt 108 posts since
    Jun 6, 2008
    Currently Being Moderated
    1. Jul 21, 2010 10:01 AM (in response to Andrea Consadori)
    Re: zenoss 3.0 search field not shown

    i think is a enterprise feature. maybe can be added a search field with less functions

  • kerickson ZenossEmployee 75 posts since
    Sep 14, 2009
    Currently Being Moderated
    3. Jul 21, 2010 12:25 PM (in response to Andrea Consadori)
    We've changed search a bit...

    Searching data uses column filters

    To search for events, you visit the events tab and use the  column filters

    Capture.PNG

     

    To search for devices, you visit the infrastructure tab and use the column filters.

     

    The nice thing about column filters is that they can be used in combination.  Example: Show me all the devices with "cent" somewhere in their name, in network segment 10.175 and that are in a Linux class.  Something that the prior search didn't let you do.

    Capture.PNG

     

    Searching organization uses left-hand colum filters

    To search for classes, locations, systems, or groups, you visit the infrastructure tab and use the left-hand column filter

    To search for reports, you visit the reports tab and use the left-hand column filter

    Capture.PNG

     

    Resetting column filters is easy if you know a trick

    Tired of a column filter in the infrastructure screen?  Click "devices" (upper left) and they're gone.

  • stephenmeier Rank: White Belt 23 posts since
    Nov 13, 2008
    Currently Being Moderated
    4. Jul 26, 2010 10:43 AM (in response to Andrea Consadori)
    Re: zenoss 3.0 search field not shown

    I am not seeing it either.  It would be very helpful if the search box returned.  It was the quickest way to go to a device from any screen. I am sure that it is a bug as it has it in the new documentation that it is in the upper right hand corner of the screen.

  • bbibeault ZenossEmployee 142 posts since
    May 19, 2009
    Currently Being Moderated
    5. Jul 26, 2010 11:07 AM (in response to stephenmeier)
    Re: zenoss 3.0 search field not shown

    The admin guide is documenting the Enterprise search features that were introduced with 3.0.x.  The guides I believe will be updated around this point, but I could be wrong.

  • nsalemme Rank: White Belt 68 posts since
    Jun 6, 2008
    Currently Being Moderated
    6. Jul 26, 2010 11:17 AM (in response to bbibeault)
    Re: zenoss 3.0 search field not shown

    In previous Zenoss Core versions, there was a Device/IP search box in the top right corner of every screen.  This was extremely help for a quick way to get to a device.  This feature was never specific to Enterprise.  I am somewhat confused at what feature was introduced in 3.x Enterprise and now not available in Core.  I would understand if a new type of search feature was added in Enterprise 3.x and Core still had the old search feature.  But it appears the search functionality has been completey removed from Core.

     

    Although I like the new UI in 3.0, I am still having to click several times to get to devices.  With the Device/IP search box, I could easily type the new of the server I wanted to see and click once and was brough there.  I'm not sure why this functionality was removed from Core.

  • bbibeault ZenossEmployee 142 posts since
    May 19, 2009
    Currently Being Moderated
    8. Jul 26, 2010 11:19 AM (in response to Andrea Consadori)
    Re: zenoss 3.0 search field not shown

    Not exactly.  The 2.5.2 core search feature moved to the devices page itself; it was essentially reproduced and integrated with the new UI.  Please see Kent's post above for the examples of the new search functionality, and where it can be accessed.

  • stephenmeier Rank: White Belt 23 posts since
    Nov 13, 2008
    Currently Being Moderated
    9. Jul 26, 2010 11:25 AM (in response to bbibeault)
    Re: zenoss 3.0 search field not shown

    Is there a way to do a feature request then?  The search feature on the infrastructure tab will not respond until the devices and classes are enumerated.  This takes away from the experience if you have to wait for them to be enumerated.  Granted, it only takes about 10-20 seconds, but when you suffer from the "used-to's" waiting for something that was redily available tends to make for cranky admins. 

  • nsalemme Rank: White Belt 68 posts since
    Jun 6, 2008
    Currently Being Moderated
    10. Jul 26, 2010 11:26 AM (in response to bbibeault)
    Re: zenoss 3.0 search field not shown

    I understand a little bit better now.  The new search capabilities are good within the device page.  I wish the Zen team had left the Device/IP box in the top right though.  So now when I want to go to Server A, I need to click on Infrastructure....wait for the list to populate with every device.....find my desired device...and then click on it.  Whereas before, I could just type Server A and hit enter and be done.  I don't quite understnd why they wouldn't have just left the old search box where it was and expanded the device search functionality within the devices page.

  • Gabe Rank: Green Belt 94 posts since
    Jun 29, 2008
    Currently Being Moderated
    11. Jul 27, 2010 4:22 AM (in response to Andrea Consadori)
    Re: zenoss 3.0 search field not shown

    to remove this basic feature is totally uncalled for, even if it is a basic criteria wanted from any user to any user friendly webpage used for anything these days.

    i hope its just a mistake when the new GUI was made.

     

    but it would worry me if something that is kept in the enterprise version, then whats next och the crosshair to be removed ?

  • Russell Ballestrini Rank: White Belt 17 posts since
    Jun 23, 2010
    Currently Being Moderated
    12. Jul 27, 2010 3:55 PM (in response to Andrea Consadori)
    Re: zenoss 3.0 search field not shown

    I feel compelled to bump ...

     

    I feel the same way.

  • Matt Ray Rank: Zen Master 2,484 posts since
    Apr 5, 2008
    Currently Being Moderated
    13. Jul 29, 2010 9:36 PM (in response to Andrea Consadori)
    Re: zenoss 3.0 search field not shown

    It was never our intention to remove any feature in 3.0. Global Device Search is now available for Core users as a ZenPack: http://community.zenoss.org/docs/DOC-7453. We will add it to the Zenoss Core product in the upcoming Fall release.

     

    Thanks,

    Matt Ray

    Zenoss Community Manager

  • stephenmeier Rank: White Belt 23 posts since
    Nov 13, 2008
    Currently Being Moderated
    14. Jul 30, 2010 11:15 AM (in response to Matt Ray)
    Re: zenoss 3.0 search field not shown

    That is awesome.  I have installed the zenpack.  Works great! I have been using zenoss since pre v1 days.  Awesome product.  I would hate to start looking for another product because of the expanding differences between core and the paid version.  Thank you for taking the time to address this issue.

More Like This

  • Retrieving data ...

Legend

  • Correct Answers - 4 points
  • Helpful Answers - 2 points