Skip navigation
1 2 3 4 Previous Next 42329 Views 45 Replies Latest reply: Aug 24, 2010 1:09 PM by Adrian Bool RSS
Scott MacKenzie Rank: White Belt 18 posts since
Jul 22, 2010
Currently Being Moderated

Jul 23, 2010 8:56 AM

Devices "missing in action"?

Hello Everyone,


This is my first attempt at leveraging zenoss and I am still on the fence.  Therefore, I thought that I would ask for some advice...


Zenoss    = version 3.0

OS          = Ubuntu 10.04 LTS (up to date)


Zenoss was installed via apt-get and seemed to install just fine.


Post the installation and subsequent "discovery" and then moving devices around into appropriate /Device/ classes my devices have started to disappear.


The problem is that when I use "IE, FF, or Chrome" my devices which originally totaled 30 now only total 6 devices in the device view ( BUT in the network view ( the proper number of device "30" show up with links that can take me to the actual device, BUT I can not see it in the devices view???.


So we have a number of missing devices???


I have followed the suggestion in the below article to:


  • Run zendmd and do the following:
> reindex() 
> commit()


But, still no joy,,,  I have restarted the services (/etc/init.d/zenoss-stack restart) and even rebooted the box.  Again, no joy...


How can I manually refresh the database or rebuild it without having to delete the devices and start again - which would really, really, suck...



Thanks in advance.


  • Ian McCracken ZenossEmployee 257 posts since
    Feb 26, 2007
    Currently Being Moderated
    1. Jul 23, 2010 11:29 AM (in response to Scott MacKenzie)
    Re: Devices "missing in action"?

    That article's a bit inaccurate. Try running:


    zencatalog run --createcatalog --forceindex


    If that doesn't get them back, it isn't a catalog issue. Do you see the correct total of devices in the left pane tree on the Infrastructure page? Or does that say 6 as well? That is, do you see "DEVICE CLASSES (30)" but only six rows are visible? Or does it say "DEVICE CLASSES (6)"?

  • Ian McCracken ZenossEmployee 257 posts since
    Feb 26, 2007
    Currently Being Moderated
    6. Jul 26, 2010 12:17 PM (in response to Scott MacKenzie)
    Re: Devices "missing in action"?

    zencatalog run debug is not a valid command, actually, which is why you're getting the traceback (though we should print usage or something, of course). Can you confirm that you ran zencatalog run --createcatalog --forceindex?



  • syspimp Rank: White Belt 17 posts since
    Apr 15, 2010
    Currently Being Moderated
    8. Jul 27, 2010 9:13 AM (in response to Scott MacKenzie)
    Re: Devices "missing in action"?

    Did you change the Production States/State Conversions in Advanced, Settings from their default values of:




    And now you see the count in the left column but not in the device view on the right? I did this and changed the names and numeric value, then none of my devices displayed. If so, try changing the Production State filter to display it.  It looks like there is a bug that the filter is always the default settings and if you change them, it won't show the device.  I made a script to pass to zendmd to force a device to a certain state (after I changed it and it disappeared), prodstate being Production in this example:


    zendmd <<-EOF





  • Mike Culverhouse Newbie 1 posts since
    Jul 27, 2010
    Currently Being Moderated
    9. Jul 27, 2010 9:31 AM (in response to syspimp)
    Re: Devices "missing in action"?


    I have the same issue after upgrading to 3.0, on Debian 5.0.5

    In my case the servers that are missing from the device-list were 'dev' servers, and I notice that there is no 'dev' option from the drop down list of production state, which is presumably why they never show up.

    I confirmed this by accessing a device via the network lists and changing the production state to test, and it was then available in the device list with the correct filter applied.

    So my question is what happened to 'dev' as I don't see any references to it now in the updated documentation.

    Or alternatively how to I add dev to the options for the production state drop down list.


    In addition I have


    In the Production States/State Conversions list in Advanced, Settings mentioned in the previous post.





  • Ian McCracken ZenossEmployee 257 posts since
    Feb 26, 2007
    Currently Being Moderated
    11. Jul 27, 2010 11:53 AM (in response to Scott MacKenzie)
    Re: Devices "missing in action"?

    Okay, so, good point all on the Production State combo being fixed on the default values! Oversight; I believe it is dynamic where it is used elsewhere (device status page, for one). I made a ticket and proposed it for 3.0.2:


    suntzu, I'm a little stumped. Let's try just searching for devices raw. Fire up zendmd and run:


    from Products.Zuul.interfaces import ICatalogTool


    Hopefully that'll give you the right number of devices.



  • s_aldinger Rank: White Belt 9 posts since
    Aug 4, 2010
    Currently Being Moderated
    13. Aug 4, 2010 7:32 PM (in response to Ian McCracken)
    Re: Devices "missing in action"?

    I having the same issue, with the same setup.


    Have 42 devices, only 28 visable... untill I try the command line fix... then 0 devices are visable.

    I ran the zendmd command, and it reports 0 devices.

  • Ian McCracken ZenossEmployee 257 posts since
    Feb 26, 2007
    Currently Being Moderated
    14. Aug 5, 2010 9:20 AM (in response to Scott MacKenzie)
    Re: Devices "missing in action"?

    Okay, let's figure this out. I've still not been able to reproduce this bug myself, so I'm sort of glad somebody else is.


    Just to confirm, you had the wrong number of devices, then you ran:


    zencatalog run --createcatalog --forceindex


    And then you had 0 devices in the UI, and no devices in the catalog?


    Can you please check $ZENHOME/etc/zencatalog.log? That nothing got indexed confuses me; hopefully there's a traceback or something to explain it.

1 2 3 4 Previous Next

More Like This

  • Retrieving data ...


  • Correct Answers - 4 points
  • Helpful Answers - 2 points