Skip navigation
14832 Views 9 Replies Latest reply: Apr 20, 2010 7:11 AM by Jimmy RSS
Jimmy Rank: White Belt 18 posts since
Apr 1, 2010
Currently Being Moderated

Apr 1, 2010 5:58 AM

Having massive Issues with Zenping

Hey everybody,

 

I'm currently setting up Zenoss as part of my Bachelor-Thesis.

I ran into some issues using zenping

The problem is that the Web-Interface is constantly reporting most devices down, which is incorrect.

I can successfully ping the devices using the zenoss user via commandline and successfully ping the devices via the command tool, but zenping is reporting all these devices as down.

 

Any suggestions appreciated

 

 

Edit:

 

I already searched this community forum as well as some others and my idea is, that it is related to zenping using python to perform the task.

If I use commandline, or the built in command tool, everything returns correct.

  • jmp242 ZenossMaster 4,060 posts since
    Mar 7, 2007
    Currently Being Moderated
    1. Apr 1, 2010 8:38 AM (in response to Jimmy)
    Re: Having massive Issues with Zenping

    Is there any ping loss from the command line? Are they taking a LONG

    time to reply? Is there any firewall between the Zenoss box and the

    remote devices? Zenoss uses a custom python library to generate the

    pings in ZenPing and they don't look the same as a normal ping necessarily.

     

    You've also left out a bunch of details - what version of Zenoss, what

    OS, what remote OS, any network details that may be relevant.

     

    See:

    http://support.microsoft.com/kb/555375

    http://www.catb.org/~esr/faqs/smart-questions.html

    for some suggestions on how to get the best and quickest answers to your

    questions.

    --

    James Pulver

    Information Technology Area Supervisor

    LEPP Computer Group

    Cornell University

     

     

     

    Jimmy wrote, On 4/1/2010 5:18 AM:

    Hey everybody,

     

    I'm currently setting up Zenoss as part of my Bachelor-Thesis.

    I ran into some issues using zenping

    The problem is that the Web-Interface is constantly reporting most devices down, which is incorrect.

    I can successfully ping the devices using the zenoss user via commandline and successfully ping the devices via the command tool, but zenping is reporting all these devices as down.

     

    Any suggestions appreciated

    >

  • guyverix ZenossMaster 846 posts since
    Jul 10, 2007
    Currently Being Moderated
    2. Apr 1, 2010 11:42 PM (in response to Jimmy)
    Re: Having massive Issues with Zenping

    Is there a chance that the monitored IP address and the DNS names dont match?  That would cause strange issues with ping replies.

     

    EG:  dig host.yourdomain.com = 192.168.1.1

    Zenping checks monitored IP 192.168.1.99

     

    Potentially this could cause a mismatch and inconsistency in your testing..

  • linkslice Rank: White Belt 53 posts since
    Jun 23, 2009
    Currently Being Moderated
    5. Apr 6, 2010 6:13 PM (in response to Jimmy)
    Re: Having massive Issues with Zenping

    run zenping run -v10 --cycle and watch for anything strange.

More Like This

  • Retrieving data ...

Legend

  • Correct Answers - 4 points
  • Helpful Answers - 2 points