Skip navigation
1 2 Previous Next 44891 Views 23 Replies Latest reply: Apr 21, 2010 12:07 PM by mlist RSS Go to original post
  • linuxdynasty ZenossMaster 156 posts since
    Apr 10, 2007

    If you have Use SSH enabled then it should be trying to run the command on the remote server and not locally. try running zencommand run -d "devicename" -v10 and see the output from their. Attached is a screenshot of my template

    Attachments:
  • linuxdynasty ZenossMaster 156 posts since
    Apr 10, 2007

    Try with out the awk statement.

  • linuxdynasty ZenossMaster 156 posts since
    Apr 10, 2007

    Does the user you are running this command as have permissions to this file? Can you do an ls -l on that file with the user you executing the command as.

     

     

     

    Allen Sanabria

    Http://linuxdynasty.orgOn Apr 2, 2010 11:57 AM, mlist <community@zenoss.org> wrote:

     

     

     

    This is the output without the awk

     

     

     

    Executing command

     

    /opt/zenoss/libexec/check_file_age -f /usr/local/nagios/libexec/check_fping

     

    against 192.168.252.59

     

    FILE_AGE CRITICAL: File not found - /usr/local/nagios/libexec/check_fping

     

    DONE in 0 seconds

     

     

     

    In attachment the template modified without the awk

  • linuxdynasty ZenossMaster 156 posts since
    Apr 10, 2007

    Well, I'm at a lost... Maybe someone else can jump in. If you tested that permissions are just fine with the pippo user, and you made sure that you are using the Enable SSH option and you did verify that the check_file_age command works on the client PC.... One last thing, That hostname zenosstst2 is that the zenoss server or the client? I just have to make sure the file you created was indeed on the client PC and that you tested that you can indeed run the check_file_age command as the pippo user and not the root user...

1 2 Previous Next

More Like This

  • Retrieving data ...

Legend

  • Correct Answers - 4 points
  • Helpful Answers - 2 points