Skip navigation
4691 Views 4 Replies Latest reply: Mar 26, 2009 1:06 PM by cjk RSS
Salmoneus Rank: White Belt 35 posts since
Sep 5, 2007
Currently Being Moderated

Feb 5, 2009 5:09 AM

Problems with Cisco ASA zenpack

I have installed the Cisco ASA zenpack on a Zenoss 2.3.2 installation, and most of it work.


I had to lower the zMaxOIDPerRequest property to 20 to please our ASA 5510 as we got errors like this:

incoming SNMP request (671 bytes) from IP address xx.xx.xx.xx Port 56790 Interface "inside" exceeds data


During installation (at prompt) the following error appeared:

CRITICAL:zen.AddToPack:Failed linking relation /zport/dmd/Manufacturers/Cisco/products/5505 ASA/instances to object /zport/dmd/Devices/Network/Firewall/devices/Cisco 5505 ASA/hw

Is it really "critical"? What can be done to fix it? I haven't found any solutions on this forum.


Another thing is that the cpu graph doesn't work. It appears, but at the bottom "missing rrd file: cpu5min_cpu5min" is shown, and no cpu data is shown. The free memory graph works fine.

Any ideas?

/Salmoneus
  • csian Newbie 1 posts since
    Nov 23, 2008
    Currently Being Moderated
    1. Feb 8, 2009 10:42 AM (in response to Salmoneus)
    free mem values negative graph??
    I have the same install error about the ASA 5505.

    My free memory graphs for ASA5550 with 4GB RAM are showing negative values which causes a memory value not met event to be sent to zensyslog.
    Other model ASA with less memory graph just fine?

    Any ideas on how to fix negative free mem values for this zenpack???

    graph:



    error:
  • cjk Newbie 2 posts since
    Mar 25, 2009
    Currently Being Moderated
    2. Mar 25, 2009 8:10 PM (in response to csian)
    ASA 5550 negative free memory values
    I'm seeing the same issue with my 5550's. When I manually query them with snmp, they are returning over 3GB of memory free. when Zenoss queries them, it stores -800MB free in the rrd file.

    On my 5510's and 5520's which have much less memory, the proper values are stored. Does anyone have any insight?
  • rustyw007 Newbie 4 posts since
    Jan 14, 2009
    Currently Being Moderated
    3. Mar 26, 2009 11:20 AM (in response to cjk)
    known issue with patch - see trac
    i expect this might fix the issue:

    http://dev.zenoss.com/trac/ticket/4556

    as the zenoss user: zenpatch 12281 to apply, then restart zenoss.
  • cjk Newbie 2 posts since
    Mar 25, 2009
    Currently Being Moderated
    4. Mar 26, 2009 1:06 PM (in response to rustyw007)
    ASA 5550
    I have installed the patch, and my 5550's are now graphing properly.

    Thanks for the pointer!

More Like This

  • Retrieving data ...