Skip navigation
26202 Views 5 Replies Latest reply: Sep 23, 2009 2:57 PM by lkwong RSS
bougie Newbie 4 posts since
Aug 3, 2007
Currently Being Moderated

Jun 9, 2008 12:34 PM

process monitoring - disable regex match

We would like zenoss to montor for an "ArchiveEngine -d L0" process. When this process monitor is created and applied, however, Zenoss matches the regex and starts monitoring for (for example):
ArchiveEngine -d L0 -l 2008_06_08-08_10_18.log -p 4813 l0-group.xml 2008/06_08/index

This is not what we want, as the ArchiveEngine restarts daily and therefore uses new log and index files. We just want to make sure that one "ArchiveEngine -d L0" process is running, and do not care that the processes arguments change from day to day.

Any suggestions for configuring this would be greatly appreciated.
  • magnachef ZenossMaster 86 posts since
    Apr 3, 2008
    Currently Being Moderated
    1. Jun 9, 2008 1:33 PM (in response to bougie)
    RE: process monitoring - disable regex match
    I believe that you just need to go into the Class -> Process -> Process name and change the Ignore Parameters option to True, under the Edit tab.
  • spyder40 Rank: White Belt 45 posts since
    Apr 17, 2008
    Currently Being Moderated
    3. Jul 8, 2008 6:30 PM (in response to bougie)
    RE: process monitoring - disable regex match
    Same issue here and haven't found an answer. We have a lot of java processes and need to monitor them individually but they get restarted on a daily basis. We want to monitor each process running with certain params individually at all times and don't care what the pid is. I've tried changing the ignoreparams and it doesn't seem to ever clear after the restart unless I do it manually. Any help will be appreciated

    zenoss 2.2
    processes are running on a Suse 10.1 or 10.2 server
  • lkwong Rank: White Belt 8 posts since
    May 21, 2009
    Currently Being Moderated
    4. Sep 23, 2009 2:57 PM (in response to spyder40)
    Re: RE: process monitoring - disable regex match

    I am also having a similar issue with Apache restarts on Solaris with Zenoss. Depending on what command was issued for starting/restarting Apache, Zenoss sees them as different processes, but they should be the same.

     

    E.g. /opt/apache/bin/httpd -f /opt/apache/conf/httpd.conf -k restart

    and /opt/apache/bin/httpd -f /opt/apache/conf/httpd.conf -k start

     

    are treated as 2 different processes but they essentially are the same and everything from -k on should be ignored. I've tried setting Ignore Parameters to true but then it ignore everything from -f on. Has anyone found a work-around?

  • jmp242 ZenossMaster 4,060 posts since
    Mar 7, 2007
    Currently Being Moderated
    5. Sep 23, 2009 2:59 PM (in response to lkwong)
    Re: process monitoring - disable regex match

    Maybe a ticket should be opened, this is either a design bug or a

    feature request.

    --

    James Pulver

    Information Technology Area Supervisor

    LEPP Computer Group

    Cornell University

     

     

     

    lkwong wrote, On 9/23/2009 2:57 PM:

    I am also having a similar issue with Apache restarts on Solaris with Zenoss. Depending on what command was issued for starting/restarting Apache, Zenoss sees them as different processes, but they should be the same.

     

    E.g. /opt/apache/bin/httpd -f /opt/apache/conf/httpd.conf -k restart

    and /opt/apache/bin/httpd -f /opt/apache/conf/httpd.conf -k start

     

    are treated as 2 different processes but they essentially are the same and everything from -k on should be ignored. I've tried setting Ignore Parameters to true but then it ignore everything from -f on. Has anyone found a work-around?

    >

More Like This

  • Retrieving data ...