Skip navigation
Currently Being Moderated

Ubuntu Source Build Notes

VERSION 2  Click to view document history
Created on: Apr 1, 2010 6:33 PM by Matt Ray - Last Modified:  Apr 1, 2010 6:52 PM by Matt Ray

These are my notes for building on Ubuntu 9.10 (Debian Source Build Notes)


 

$ sudo apt-get install rsync python-dev build-essential make bzip2 sudo subversion sysv-rc-conf snmpd swig autoconf mysql-server-5.0 libmysqlclient15-dev libmysqlclient15off ttf-liberation ttf-linux-libertine unzip

 

sudo adduser zenoss
sudo mkdir /usr/local/zenoss
sudo chown zenoss /usr/local/zenoss
sudo su - zenoss

 

#add these to the .bashrc
export ZENHOME=/usr/local/zenoss
export PYTHONPATH=$ZENHOME/lib/python
export PATH=$ZENHOME/bin:$PATH

 

. ~/.bashrc

 

#2.5.X
zenoss# svn co http://dev.zenoss.org/svn/branches/zenoss-2.5.x/inst 2.5.x
zenoss# cd 2.5.x
zenoss# SVNTAG=branches/2.5.x ./install.sh

 

Changes for trunk


 

#trunk
svn co http://dev.zenoss.org/svn/trunk/inst zenossinst
cd zenossinst
./install.sh

 


This error means need the Sun JDK, but it's just a warning (and UI performance will be slow)
export JSBUILDER=/home/zenoss/zenossinst/build/JSBuilder2.jar && \
        DESTDIR= /home/zenoss/zenossinst/buildjs.sh
This script requires the Sun JDK 1.6 or greater.

 

This was found on the first pass on QA Test Day

http://dev.zenoss.org/trac/ticket/6395

 

The work-around appears to be

apt-get install install librrd4

 

I was building on an Amazon EC2 instance without access to port 8080, so I'll need to start another instance with that opened up to see if it actually comes up

Comments (0)