Skip navigation
Currently Being Moderated

Dev chat 10/15/2009

VERSION 1 
Created on: Oct 15, 2009 9:04 PM by Matt Ray - Last Modified:  Oct 15, 2009 9:09 PM by Matt Ray
mrayzenoss: defect review ran a bit long, but JP should be here in a minute
rmatte: sounds good
mrayzenoss: the other good news is we have a new developer, I believe he'll be starting Monday
mrayzenoss: also named JP
exarkun: *gets creeped out*
mrayzenoss: so jplouis and I are here for questions, other Zenoss folks may chip in as well
jb: ok.. so, I have deleted a process monitor, reindexed, and re-modeled, and alerts are still firing off for the processes that I have deleted..
jb: how do I rid of them?
mrayzenoss has changed the topic to: Zenoss Developers are here (10:08:06 AM)
exarkun: What's the intended workflow for developing skins?  I'm having the problem I described here: http://community.zenoss.org/thread/11724?tstart=0
twm1010: jb: use the context drop down to push changes to the collectors
rmatte: twm1010: I'm pretty sure jb's problem has been ongoing for like a week now
jb: yah
jb:
rmatte: jplouis: any idea on how to fix jb's problem?  I've run out of ideas.
jplouis: jb is there a process instance on your device after you re-modeled?
jb: jplouis: no, no instance on the device
jb: jplouis: at least in the "OS Processes" box
jplouis: go to the Process link on the left and look for the process definition
jb: its gone
jplouis: there is nothing in /Processes ?
jb: not the process that I deleted..
jb: i do have other processes
jb: Process not running: w3wp.exe -a \\.\pipe\iisipmb826eb47-186b-435b-a1ba-646223c2237f -t 20 -ap "DefaultAppPool"
jb: there is no w3wp.exe process any longer..
rmatte: basically he's removed the process, pushed changes to collector, I had him reindex in zendmd in case it was an indexing issue (I had that in the past with process monitoring), nothing has worked.
jplouis: did you restart zenprocess?
jb: yes
jb: i'll do it onc emore
jplouis: jb in zendmd can you do the following:
mrayzenoss: exarkun: you're doing a zopectl restart after updating your skins right?
jplouis: d = dmd.Devices.findDevice("")
jplouis:  d.os.processes()
exarkun: mrayzenoss: A "zenoss stop; zenoss start", which I think is just as good in this context
mrayzenoss: yeah
twm1010: So... where stands Zenoss 2.5 ?
exarkun: Even more strangely (to me) than the failure I described in that post, I've now also deleted all the objects that use this skin, uninstalled the zenpack, reinstalled the zenpack, created new objects, and they also still have the old version of the skin.
exarkun: Oh, I renamed the skin too, and the new name never had the old content in it.
jb: hrm
jb: SyntaxError: invalid syntax
mrayzenoss: twm1010: we're trying to get a Release Candidate out
exarkun: I have no idea how Zenoss could still find the old version of the skin to render.
jb: on the " d.os.processes()"
exarkun: (except I guess it could be buried in the zodb somewhere)
cgibbons: hurm
jplouis: jb what does d.os return
exarkun: Also if I visit .../portal_skins/manage and find the skin in question, it shows up as having the new contents.  There's no sign of the old contents anywhere.
jb:
rmatte: jb: don't indent the second line
jb: ah yeah
jb: dumb me.
jplouis: yeah, that will do it
rmatte:
jb: doesn't look like the processes are there that I have deleted
jb: also, the alerts haven't came back again since I restarted zenprocess
rmatte: well, maybe that's all you needed was one last restart
jb: perhaps
rmatte: give it a bit and see if the alerts come back
jplouis: zenprocess isn't the best at getting device updates/changes
rmatte: zenprocess really need quite a bit of work in my opinion, it's really the weakest link right now in terms of snmp monitoring
jplouis: some of that has changed in zenprocess for 2.5; hopefully they will make zenprocess respond to changes in a timely manner
rmatte: indeed
cgibbons: zenprocess is not my favorite, either
rmatte: hehe
exarkun: Anyone have any other ideas about my skin question?
jplouis: I got nothing, reinstalling the zenpack and restarting zenoss(zope) should reload the skin
twm1010: maybe a pack to remove deleted objects?
exarkun: I'll try it.  How do I do a pack?
exarkun: *opens the admin guide*
exarkun: ah, zenpack.py, okay
andrewp: Can anybody here help w/ HTTPMonitor ZenPack?
kobalt: rmatte, I found what my 32 vs 64 bit counters issue was.... an access list lol
rmatte: andrewp: what do you need help with?
rmatte: kobalt: snmp access list you mean?
kobalt: rmatte, yeah the zenoss server didnt have access to the ifHcInOctects mibs
rmatte: yup, that'd do it
rmatte:
rmatte: told you it sounded like more of a device issue
kobalt: fix that and Im on my way
kobalt: yeah
andrewp: I'm having an issue with it not properly "de-duplicating" events.  It seems like one HTTP monitor clears the events of another.  So therefore if a site is down for an hour, no matter what the check interval is, it always shows the event count as 1
rmatte: good stuff
mrayzenoss: andrewp: which version are you running?
andrewp: Zenoss version 2.4.5 HTTPMonitor version 2.0.1
andrewp: The idea is that I want to put an alerting rule so it takes a couple of timeouts for me to get a page, but with the count always being "1" that currently does not work.
twm1010: And it works fine when you're only testing one url?
jplouis: httpmonitor uses zencommand?
andrewp: I haven't tried testing one URL, but I've tried putting in a special event eventclass for each monitor.
andrewp: I think it uses zencommand - the nagios CHECK_HTTP script
rmatte: jplouis: yes, it does
jplouis: and the special eventclass for each datasource didn't work?
andrewp: No,, it didn't.  And I can actually see the "clear" messages come through before it immediately generates another event.
jplouis: hmm, there is a patch for zencommand; it may apply to this case
mrayzenoss: exarkun: is that 2.4.5 or 2.5?
mrayzenoss: jplouis: http://dev.zenoss.org/trac/ticket/5494 ?
jplouis: yep, that one
andrewp: hmm. that does look awful suspect
jplouis: patch number is [15003]
andrewp: I'll definitely give that a try! Thanks!
exarkun: mrayzenoss: 2.4.5
rmatte: wasn't that one patched in 2.4.5?
rmatte: I thought that 2.4.4 addressed Jane's ticket then 2.4.5 addressed 5494?
exarkun: Maybe the way I'm developing my data source (what the skin is associated with) is wrong.  If I want to change the implementation of a data source that's already been instantiated in a Zenoss server, what do I need to do?
mrayzenoss: I really don't know... what are you trying to do exactly?
rmatte: exarkun: if you were to write up what your issue is in detail (a lot of detail) along with what exactly you're trying to accomplish and a list of errors that you are experiencing, then post it on the forums you would most likely have better luck
rmatte: offering up a cash reward for a solution tends to work as well
exarkun: I posted one question to the forums.  I might post some more.  Maybe I'll get an answer at some point.
exarkun: I don't think I'm doing anything unusual.  In fact, I haven't really /done/ anything yet.  I have a custom data source class that has no behavior at all.  I have a skin file that's 1 line long.  I'm still figuring things out, but I'm having a lot of trouble with the workflow.  For most projects, I start writing some tests, I implement stuff until they pass, and repeat.  That doesn't seem to apply for ZenPack development.  At least not any of the parts I'v
rmatte: well, I've done ZenPack development and I've never gotten in to what you're trying to do, so I can't personally offer much assistance
rmatte: I wish I did have the time to actually study zenpack development in more depth
mrayzenoss: the only custom data sources I'm aware of are from Egor... WMI, WBEM and ODBC
rmatte: yeh, thought the WMI pack completely breaks in King Crab
rmatte: and I'd imagine WBEM and ODBC packs break as well
rmatte: s/thought/though
rmatte: ...and I doubt he'll have time to fix them before the King Crab release
rmatte: so I can see that being a bit of an issue for a lot of people
exarkun: I haven't looked at those data sources yet.  I probably should, I'm sure that will help me understand important stuff.  But since they're "finished" products, they don't really tell me anything about development workflow.
mrayzenoss: we're trying to get a Beta 5 out today, maybe I can get Egor or someone to look at how they get broken in 2.5 and get them fixed ahead of time
twm1010: mrayzenoss: that would be nice, WMI datasource keeps me on 2.4.x until thats squared away
cgibbons: the WMI one only breaks because he was using a common daemon collector that zenwin & zeneventlog used; they both got rewritten in 2.5 to use the new collector framework, so that common class was removed. but the datasource, etc. stuff should still be fine.
mrayzenoss has changed the topic to: Zenoss 2.5 Beta needs Testers: http://tinyurl.com/ylz46ca (11:34:42 AM)
Comments (0)